Browsed by
标签: Qt5

在 Ubuntu 20.04 系统上运行 miniSIPServer

在 Ubuntu 20.04 系统上运行 miniSIPServer

Ubuntu 20.04 是最新的长期支持版本,因此 miniSIPServer 也必须支持这个新发布的版本。

不幸的是,Ubuntu 20.04 版本砍掉了对 Qt4 的支持,因此我们需要采用 Qt5 开发库更新 miniSIPServer。 miniSIPServer 升级到 V37 (build 20200424) 后,可以成功支持 Ubuntu 20.04系统版本,请参考下图。

miniSIPServer 运行在 Ubuntu 20.04 系统

另外,miniSIPServer 的 Windows 版本仍然选择停留在 Qt4 程序库,因为我们目前还需要支持部分客户的老旧系统版本,例如 XP、7等。在开发计划中, V38 版本将全部迁移到 Qt5 版本,同时将正式告别 XP 等老旧系统。